Forum list » E-commerce »
Language conflict
Pages:  1
(62 posts)

Language conflict

I have changed the language in the shoe demo. I changed it to Norwegian, and added Swedish and Danish. I have add tried to go over and set the default language (Norwegian) everywhere, but when I try to add a product to the shopping basket, I get the server error  "This session does not have access to update changes to content in this language".

Any help for this one?

 

(144 posts)

Re:Language conflict

How did you change the language to Norwegian?

The correct procedure would be to go to the ontology module. Choose the cultures tab. Open the English culture, and click on the change LCID button. 

 

Attachments
(62 posts)

Re:Language conflict

I added 3 new cultures in the ontology module (culture tab). The english culture is still there. But I have deleted most of the content, and added Norwegian content. Specific nodes, such as Webshop, Payment, Shipping --->  I added norwegian and removed English.

In my site node, I only use the 3 new cultures, not the english one.

(144 posts)

Re:Language conflict

As you have guessed, you get the error since you try to update a version of a node that is derived (it doesn't have content in the current language).

If you had changed the English culture to Norwegian, you wouldn't have had this problem, since all nodes in the system would be changed to norwegian. Now there are some nodes in the system with only english content.

There are no quick fixes for this, apart from making sure each node has content in one of the languages used in the site. 

- Check which language the template is in, using WAFContext.Session.LCID. Just print the LCID in the page somewhere.

- Empty the shopping cart if it has any content. Then try to add a new product to the cart. This should create a new Order node, in the current language. 

 

 

(62 posts)

Re:Language conflict

Ok, seems like I am stuck :/

So I did it all over again. I took a new copy of your database. I changed the culture, did a full rebuild, changed the currency in the webshop. It works :)

What do you recommend to do with the culture nodes in the site? Should I change the existing one, or create a new? In the definition file, I can see 1033 is still in use, not 1044. Should it be 1044, after the rebuild?